summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-09-23 07:04:03 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 13:17:51 +0900
commit7ee28b3a9ddd3e02fc12ae425bb7f391f7eb827f (patch)
tree989192ad6bbf2add8e7793207061d552abbfc76a
parentfe9d09dca4674c1a309eefe5fbf324c61ba975d1 (diff)
downloadguix-patches-7ee28b3a9ddd3e02fc12ae425bb7f391f7eb827f.tar
guix-patches-7ee28b3a9ddd3e02fc12ae425bb7f391f7eb827f.tar.gz
gnu: Add cppgir-for-telegram-desktop.
* gnu/packages/glib.scm (cppgir-for-telegram-desktop): New variable. Change-Id: Ib9ca3bd376f32d13939adabd2c52e1eb24e2ddcb Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/glib.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a479199cdd..a15a7ce58a 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1621,3 +1621,22 @@ that uses asynchronous and future-based APIs.")
introspection annotations into a set of C++ files defining suitable
namespaces, classes and other types that together form a C++ binding.")
(license license:expat)))
+
+;; telegram-desktop requires a more recent version of cppgir
+(define-public cppgir-for-telegram-desktop
+ (let ((commit "9c4f5820d94d62ab451501f016bfea97156518f4")
+ (revision "0"))
+ (package
+ (inherit cppgir)
+ (name "cppgir-for-telegram-desktop")
+ (version (git-version "2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.com/mnauw/cppgir")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fa9nf4yljfarihaqj5kd98yysrky7q316mh6l5b1rq39ga15k9b")))))))