summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-25 09:52:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-25 09:52:03 +0300
commit93d6ce6a71e3dca50f305ac5aa94f84a3cf9f135 (patch)
treeda02754a39c613cf99385adaf0ddc677757353d1
parentfdd2a6c4c039c68dc006c83b6974f95e42353df0 (diff)
downloadguix-patches-93d6ce6a71e3dca50f305ac5aa94f84a3cf9f135.tar
guix-patches-93d6ce6a71e3dca50f305ac5aa94f84a3cf9f135.tar.gz
gnu: inkscape: Fix build on armhf-linux.
* gnu/packages/inkscape.scm (inkscape/stable)[arguments]: Add the custom 'fix-32bit-size_t-format phase when building for armhf-linux. Change-Id: I45f371babd2afc6d6f63d30e5f909b702410833e
-rw-r--r--gnu/packages/inkscape.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 524277fc2b..13e1652f87 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -204,7 +204,8 @@ endif()~%~%"
(("add_pdfinput_test\\(font-(spacing|style) 1 draw-all" all)
(string-append "#" all))))))
'())
- #$@(if (target-x86-32?)
+ #$@(if (or (target-x86-32?)
+ (target-arm32?))
'((add-after 'unpack 'fix-32bit-size_t-format
(lambda _
;; Fix an error due to format type mismatch with 32-bit size_t.