summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-09-05 21:23:35 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-25 16:17:27 +0200
commita1dc5ac832a106d46450961e78e7db3f83bf2bff (patch)
tree8e9b0c9aded42efc2ea69d4994d0f55a27a589c8
parentad1664f8987f36c6efa0b2f82cc54e31cce38ede (diff)
downloadguix-patches-a1dc5ac832a106d46450961e78e7db3f83bf2bff.tar
guix-patches-a1dc5ac832a106d46450961e78e7db3f83bf2bff.tar.gz
gnu: Add julia-staticarrayscore.
* gnu/packages/julia-xyz.scm (julia-staticarrayscore): New variable. Change-Id: I17cf746b6c473685505fbdf70dda5a97ddf20148 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 12a5e87628..f0231471d8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -6032,6 +6032,29 @@ statically sized arrays in Julia, using the abstract type
linear algebra operations.")
(license license:expat)))
+(define-public julia-staticarrayscore
+ (package
+ (name "julia-staticarrayscore")
+ (version "1.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/StaticArraysCore.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dvi9c4abjzvdn6lyr6adpc8qf4432rg3p5z96a3rc3nlsvfns9y"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaArrays/StaticArraysCore.jl")
+ (synopsis "Common types and functions for static arrays")
+ (description
+ "This package provides definitions for most of the
+primary types and functions in @code{StaticArrays.jl}. This enables
+downstream packages to implement new methods on these types without
+depending on the entirety of @code{StaticArrays.jl}.")
+ (license license:expat)))
+
(define-public julia-statsapi
(package
(name "julia-statsapi")