summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-09-05 20:39:09 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-25 16:17:04 +0200
commitb7250a27b6bef021aba4ed5003d8b9dcf3d5530e (patch)
treeff2ac2e947bc1e0dfca35b600ff6437ab4f43156
parentc250033aa69f35e64949a87fd8482b253dd416b4 (diff)
downloadguix-patches-b7250a27b6bef021aba4ed5003d8b9dcf3d5530e.tar
guix-patches-b7250a27b6bef021aba4ed5003d8b9dcf3d5530e.tar.gz
gnu: Add julia-bijections.
* gnu/packages/julia-xyz.scm (julia-bijections): New variable. Change-Id: I23f50b2b148198446dc85cb3f217a48390f6ce88 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b068dee61f..9d11961674 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -506,6 +506,28 @@ not performance, so this package should be used for precision experiments
only, not performance experiments.")
(license license:expat)))
+(define-public julia-bijections
+ (package
+ (name "julia-bijections")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scheinerman/Bijections.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f58cvjvrjh6xzi6zzbakdicdhpkyzwdp15fg2y12vslgmab2k9h"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/scheinerman/Bijections.jl")
+ (synopsis "Bijection data type for Julia")
+ (description
+ "This package defines the @code{Bijection} data type.
+A @code{Bijection} data structure behaves similar to a @code{Dict},
+however it prevents assigning the same value to two different keys.")
+ (license license:expat)))
+
(define-public julia-bioalignments
(package
(name "julia-bioalignments")