summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2024-08-05 17:43:10 +0000
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:48 +0200
commita4319550a0b4d131199c0d6ffbb7fe791072046f (patch)
treee798fa319bed42a91303b564364b0c946b1ae4dc
parent25f4fd8542daa9d3ca8c44ccbd67b37644038399 (diff)
downloadguix-patches-a4319550a0b4d131199c0d6ffbb7fe791072046f.tar
guix-patches-a4319550a0b4d131199c0d6ffbb7fe791072046f.tar.gz
gnu: inkscape: Skip failing tests on i686-linux.
* gnu/packages/inkscape.scm (inkscape/stable)[arguments]: Add ‘fix-32bit-size_t-format’ phase on i686. In ‘check’ phase, list additional failing tests on i686. (inkscape)[arguments]: Do not restore ‘check’ phase on i686. Change-Id: Id4b11ac7aa725a8a55d04bca221319201e488940 Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/inkscape.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 8d8dac4fa8..524277fc2b 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -204,6 +204,13 @@ endif()~%~%"
(("add_pdfinput_test\\(font-(spacing|style) 1 draw-all" all)
(string-append "#" all))))))
'())
+ #$@(if (target-x86-32?)
+ '((add-after 'unpack 'fix-32bit-size_t-format
+ (lambda _
+ ;; Fix an error due to format type mismatch with 32-bit size_t.
+ (substitute* "testfiles/src/visual-bounds-test.cpp"
+ (("%lu") "%u")))))
+ '())
(add-after 'unpack 'set-home
;; Mute Inkscape warnings during tests.
(lambda _
@@ -239,7 +246,15 @@ endif()~%~%"
"cli_export-ps-level_3_check_output"
"cli_export-ps-level_3_content_check_output"
"cli_export-ps-level_2_content_check_output"
- "cli_export-ps-level_2_check_output")))
+ "cli_export-ps-level_2_check_output"
+ ;; These fail on i686 but not x86-64
+ #$@(if (target-x86-32?)
+ '("cli_pdfinput-font-spacing_check_output"
+ "cli_pdfinput-font-style_check_output"
+ "cli_pdfinput-latex_check_output"
+ "cli_pdfinput-multi-page-sample_check_output"
+ "test_lpe")
+ '()))))
(invoke "make" "-j" job-count "tests")
(invoke "ctest" "-j" job-count
"--output-on-error"
@@ -340,10 +355,13 @@ as the native format.")
#~(delete "-DWITH_IMAGE_MAGICK=OFF" #$flags))
((#:phases phases)
#~(modify-phases #$phases
- (replace 'check
- ;; Re-instate the tests disabled in inskcape/stable, now that
- ;; their ImageMagick requirement is satisfied.
- (assoc-ref %standard-phases 'check))
+ #$@(if (target-x86-32?)
+ #~() ;XXX: there are remaining failures on i686
+ #~((replace 'check
+ ;; Re-instate the tests disabled in inkscape/stable, now that
+ ;; their ImageMagick requirement is satisfied.
+ (assoc-ref %standard-phases 'check))))
+
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda _