summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 21:58:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-23 21:58:07 +0100
commit43e0baa5db8e19014ad83cf373007174f13967a7 (patch)
tree649686a0a793028d19b21399832ff081e9531850
parentd3a25d86087018fa02639768cefd3dfbdb735eeb (diff)
downloadguix-patches-43e0baa5db8e19014ad83cf373007174f13967a7.tar
guix-patches-43e0baa5db8e19014ad83cf373007174f13967a7.tar.gz
gnu: actionlint: Improve package style.
* gnu/packages/check.scm (actionlint): Adjust indentation. [arguments]: Use list style. [native-inputs]: Merge with [inputs] as for Golang they are only required during build time for the final command. Change-Id: I754c1631be653304c8ebac8263745b77df6ad890
-rw-r--r--gnu/packages/check.scm42
1 files changed, 22 insertions, 20 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a3fa6d8d6c..f451afa97e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1300,28 +1300,30 @@ but it works for any C/C++ project.")
(package
(name "actionlint")
(version "1.7.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rhysd/actionlint")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0h84gb2mfhsrv1vqb3s2ff9j43zhg0ga49af6h2wdssbrs7w3vcy"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rhysd/actionlint")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h84gb2mfhsrv1vqb3s2ff9j43zhg0ga49af6h2wdssbrs7w3vcy"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/rhysd/actionlint/cmd/actionlint"
- #:unpack-path "github.com/rhysd/actionlint"
- #:install-source? #f))
- (inputs (list go-github-com-fatih-color
- go-github-com-mattn-go-colorable
- go-github-com-mattn-go-runewidth
- go-github-com-robfig-cron
- go-golang-org-x-sync
- go-golang-org-x-sync
- go-gopkg-in-yaml-v3))
- (native-inputs (list go-github-com-google-go-cmp))
+ (list
+ #:install-source? #f
+ #:import-path "github.com/rhysd/actionlint/cmd/actionlint"
+ #:unpack-path "github.com/rhysd/actionlint"))
+ (native-inputs
+ (list go-github-com-fatih-color
+ go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-runewidth
+ go-github-com-robfig-cron
+ go-golang-org-x-sync
+ go-golang-org-x-sync
+ go-github-com-google-go-cmp
+ go-gopkg-in-yaml-v3))
(home-page "https://rhysd.github.io/actionlint/")
(synopsis "Static checker for GitHub Actions workflow files")
(description