summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-09-04 13:18:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-04 13:18:59 +0200
commitbaf8c5cf80bf160a147d9c97ce7d02e85a8158b2 (patch)
tree5723d2e2fa0bb0e91d71ee0a89f0aec69e74bed3
parent4395ed12280f2aab3520be61ab736faff936a51d (diff)
downloadguix-patches-baf8c5cf80bf160a147d9c97ce7d02e85a8158b2.tar
guix-patches-baf8c5cf80bf160a147d9c97ce7d02e85a8158b2.tar.gz
gnu: glfw-3.4: Fix build.
* gnu/packages/glfw.scm (glfw-3.4)[arguments]: Don't build out of source. Change-Id: I42437c60f7adbc0b087f7149b17181fbc8eab4ce
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 101dffa01c..849ca076dc 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -1025,7 +1025,12 @@ and surfaces, receiving input and events.")
(base32
"1sd396kkn53myp61kxrd18h7b1q4ix173hhxhvl0iz8j4x5h1v5m"))))
(native-inputs (modify-inputs (package-native-inputs glfw)
- (prepend pkg-config)))))
+ (prepend pkg-config)))
+ ;; When building out of source, the install phase fails with:
+ ;; file INSTALL cannot find "/tmp/guix-build-glfw-3.4.drv-0/build/docs/html":
+ ;; No such file or directory
+ (arguments (substitute-keyword-arguments (package-arguments glfw)
+ ((#:out-of-source? _ #f) #f)))))
(define-public nanovg-for-extempore
(let ((version "0.7.1")