summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 09:14:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:09 +0100
commitd54385946ab94ae500cd30ec38df599dd4a66d76 (patch)
tree775e8f103d832b7a2da275bdf5263e2825aa48e3
parent9579f37bcc1c834bda4ae6233685e8607d9a1169 (diff)
downloadguix-patches-d54385946ab94ae500cd30ec38df599dd4a66d76.tar
guix-patches-d54385946ab94ae500cd30ec38df599dd4a66d76.tar.gz
gnu: go-github-com-gsterjov-go-libsecret: Improve package style.
* gnu/packages/golang.scm (go-github-com-gsterjov-go-libsecret): Fix indentation. Swap [native-inputs] with [propagated-inputs] as go-gihub-com-godubs-dbus is required during build time. Adjust order of fields. [synopsis]: Apply TexLive formatting. [description]: Likewise. Change-Id: I6ed08095839b6e76de070699753e088f86e256a1
-rw-r--r--gnu/packages/golang.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ba5bc35b14..a954e24365 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7599,30 +7599,30 @@ aware of your profiles and configuration in ~/.aws/config.")
(license license:expat)))
(define-public go-github-com-gsterjov-go-libsecret
- (package
- (name "go-github-com-gsterjov-go-libsecret")
- (version "0.0.0-20161001094733-a6f4afe4910c")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gsterjov/go-libsecret")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09zaiadnll83vs22ib89agg7anj0blw5fywvmckxllsgif6ak6v7"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-godbus-dbus))
- (arguments
- '(#:import-path "github.com/gsterjov/go-libsecret"
- #:phases %standard-phases))
- (synopsis "Manage secrets via the \"Secret Service\" DBus API")
- (description
- "This native Go library manages secrets via the freedesktop.org
-\"Secret Service\" DBus interface.")
- (home-page "https://github.com/gsterjov/go-libsecret")
- (license license:expat)))
+ (package
+ (name "go-github-com-gsterjov-go-libsecret")
+ (version "0.0.0-20161001094733-a6f4afe4910c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gsterjov/go-libsecret")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09zaiadnll83vs22ib89agg7anj0blw5fywvmckxllsgif6ak6v7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gsterjov/go-libsecret"))
+ (propagated-inputs
+ (list go-github-com-godbus-dbus))
+ (home-page "https://github.com/gsterjov/go-libsecret")
+ (synopsis "Manage secrets via the @code{Secret Service} DBus API")
+ (description
+ "This native Go library manages secrets via the freedesktop.org
+@code{Secret Service} DBus interface.")
+ (license license:expat)))
(define-public go-github-com-mtibben-androiddnsfix
(let ((commit "ff02804463540c36e3a148dcf4b009d003cf2a31")