summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-08 15:40:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-09 21:05:18 +0100
commit672211e8344f13b8bc6e15017bfc84dbe43e0440 (patch)
tree4e6d7231d3f052497019dde9a451fd0fe7d23f03
parent319178c16e45979fddda1679dabe66ef07c5205b (diff)
downloadguix-patches-672211e8344f13b8bc6e15017bfc84dbe43e0440.tar
guix-patches-672211e8344f13b8bc6e15017bfc84dbe43e0440.tar.gz
gnu: Add go-github-com-mikioh-tcpinfo.
* gnu/packages/golang-web.scm (go-github-com-mikioh-tcpinfo): New variable. Change-Id: I1725c2721d0a69044eab2507fefb656f5c19d01a
-rw-r--r--gnu/packages/golang-web.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 7de5a21031..b18498c66a 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3151,6 +3151,39 @@ Domain Name Service}. The API follows the less-is-more principle, by
presenting a small interface.")
(license license:bsd-3)))
+(define-public go-github-com-mikioh-tcpinfo
+ (package
+ (name "go-github-com-mikioh-tcpinfo")
+ (version "0.0.0-20190314235526-30a79bb1804b")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mikioh/tcpinfo")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "053dwvlawhhm7ly2vhjziqdifnqp12dav6rsbxbcivjjzyzw987f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mikioh/tcpinfo"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; It inroduce cycle with go-github-com-mikioh-tcp.
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file "example_test.go")))))))
+ (propagated-inputs
+ (list go-github-com-mikioh-tcpopt))
+ (home-page "https://github.com/mikioh/tcpinfo")
+ (synopsis "Encoding and decoding of TCP-level socket options")
+ (description
+ "This package implements an encoding and decoding of TCP-level socket
+options regarding connection information.")
+ (license license:bsd-2)))
+
(define-public go-github-com-mikioh-tcpopt
(package
(name "go-github-com-mikioh-tcpopt")