summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-12 17:06:40 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-12 17:11:47 +0900
commitf5449685143be0805a8a9b54ddecee94e368c6e9 (patch)
treefbb1e45c5058d2550099078ad3fb35cdd10ea93b
parent51ba1e375e54c67bfdd3d25f5eea186eacaf72e8 (diff)
downloadguix-patches-f5449685143be0805a8a9b54ddecee94e368c6e9.tar
guix-patches-f5449685143be0805a8a9b54ddecee94e368c6e9.tar.gz
gnu: guix-daemon: Remove broken 'change-default-guix' phase.base-for-issue-73212base-for-issue-73197base-for-issue-73196
It has no effect, probably due to the '+' in the pattern not being escaped. We also don't want to refer to /var/guix/profiles/per-user/root/bin/guix anymore, which may not exist (for Guix System users that have never ran 'guix pull' has root). The 'guix' command used is that specified via the build system, which is $(bindir)/guix. * gnu/packages/package-management.scm (guix-daemon) [phases]: Delete change-default-guix phase. Change-Id: If4703334f34aac3486ff655af7d8d4c2ccf0a0eb
-rw-r--r--gnu/packages/package-management.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 5d049ada44..955e7d3626 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -614,19 +614,6 @@ the Nix package manager.")
((#:phases phases '%standard-phases)
`(modify-phases ,phases
(delete 'set-font-path)
- (add-after 'unpack 'change-default-guix
- (lambda _
- ;; We need to tell 'guix-daemon' which 'guix' command to use.
- ;; Here we use a questionable hack where we hard-code root's
- ;; current guix, which could be wrong (XXX). Note that scripts
- ;; like 'guix perform-download' do not run as root so we assume
- ;; that they have access to /var/guix/profiles/per-user/root.
- (substitute* "nix/libstore/globals.cc"
- (("guixProgram = (.*)nixBinDir + \"/guix\"" _ before)
- (string-append "guixProgram = " before
- "/var/guix/profiles/per-user/root\
-/current-guix/bin/guix")))
- #t))
(replace 'build
(lambda _
(invoke "make" "nix/libstore/schema.sql.hh")