summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-09-07 11:51:26 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-12 19:10:03 +0200
commit8cb2ef0b89b1c821b10744a3b11d99a954bcb6c4 (patch)
tree85b363e0f5556ae95b531cc302ecba24a1c61e4e
parent0d231b12d932c9a1e3e1a919bee578f6b24dc8f2 (diff)
downloadguix-patches-8cb2ef0b89b1c821b10744a3b11d99a954bcb6c4.tar
guix-patches-8cb2ef0b89b1c821b10744a3b11d99a954bcb6c4.tar.gz
gnu: Add clojure-data-json.
* gnu/packages/clojure.scm (clojure-data-json): New variable. Change-Id: Id5da429fe375c656842250ed88d84d281954cec9
-rw-r--r--gnu/packages/clojure.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index d315fc9187..c3f34e61a6 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -397,6 +397,32 @@ CSV data. @code{data.csv} follows the RFC4180 specification but is more
relaxed.")
(license license:epl1.0)))
+(define-public clojure-data-json
+ (package
+ (name "clojure-data-json")
+ (version "2.5.0")
+ (home-page "https://github.com/clojure/data.json")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04k3fr9y1gp337h0d2zxam3aa3hl046r2g2qiizn7aq0rq6311p9"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure")
+ #:test-dirs '("src/test/clojure")
+ #:doc-dirs '()))
+ (native-inputs (list clojure-test-check))
+ (synopsis "Clojure library for reading and writing JSON data")
+ (description "@code{data.json} is a Clojure library for reading and
+writing JSON data. @code{data.xml} is compliant with the JSON spec and has no
+external dependencies")
+ (license license:epl1.0)))
+
(define-public clojure-data-xml
(package
(name "clojure-data-xml")