summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-15 20:26:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-16 09:08:38 +0300
commit4ebb2ad0f63871402fadd1510a36fe22e306c071 (patch)
tree145823500864d090323d85f5e0cf3442bca4cb0b
parentc2d4f8dddaaa74f17cb732fae638b666f6db23e5 (diff)
downloadguix-patches-4ebb2ad0f63871402fadd1510a36fe22e306c071.tar
guix-patches-4ebb2ad0f63871402fadd1510a36fe22e306c071.tar.gz
gnu: hunspell-dict-el: Reflow with guix style.
* gnu/packages/hunspell.scm (hunspell-dict-el): Reformat package definition using 'guix style'. Change-Id: Ifd741ec3aea6a25b3c2fecdb0d21caf8d5f59b94
-rw-r--r--gnu/packages/hunspell.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/hunspell.scm b/gnu/packages/hunspell.scm
index e228a844bf..22bc8a5311 100644
--- a/gnu/packages/hunspell.scm
+++ b/gnu/packages/hunspell.scm
@@ -273,28 +273,25 @@ spell-checking library.")
(version "0.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.thanosapollo.org/hunspell-dict-el")
- (commit commit)))
- (sha256
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.thanosapollo.org/hunspell-dict-el")
+ (commit commit)))
+ (sha256
(base32 "0z9nyfy50c0bjvvm42xwd3npjpp07a9slm3gfgvxanyqm7djrmb1"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'build)
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/hunspell/")))
- (install-file "el_GR.aff" share)
- (install-file "el_GR.dic" share)
- #t))))
- #:tests? #f))
- (native-inputs
- (list hunspell ispell perl))
+ `(#:phases (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share/hunspell/")))
+ (install-file "el_GR.aff" share)
+ (install-file "el_GR.dic" share) #t))))
+ #:tests? #f))
+ (native-inputs (list hunspell ispell perl))
(synopsis "Hunspell Greek/Hellenic dictionary")
(description "This package provides a dictionary for the Hunspell
spell-checking library.")