summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-15 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commit7efce3966293f833be9a0bb24e3c5571a6033900 (patch)
tree4b3d3ec42aea6a7b138d12e3fc60e6124e455f77
parent6ab1a5bf5178f49612eb19ab1dbae9223b6c9da1 (diff)
downloadguix-patches-7efce3966293f833be9a0bb24e3c5571a6033900.tar
guix-patches-7efce3966293f833be9a0bb24e3c5571a6033900.tar.gz
gnu: boost-signals2: Use G-expressions.
* gnu/packages/boost.scm (boost-signals2)[arguments]: Rewrite as G-expressions. Change-Id: I83c05f97089cae8a14fedf52c34e898addfb5701
-rw-r--r--gnu/packages/boost.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 233ef5bd87..d090c52d8d 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -411,13 +411,14 @@ Boost.Thread.")
(base32 "101ayw7dz4gdvva2yzyrfad69w4xbvv3man83xwqjbkib3a92ca8"))))
(build-system trivial-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source")))
- (copy-recursively (string-append source "/include")
- (string-append %output "/include"))))))
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source")))
+ (copy-recursively (string-append source "/include")
+ (string-append %output "/include"))))))
(home-page "https://github.com/boostorg/signals2")
(synopsis "Boost.Signals2 library")
(description "The Boost.Signals2 library is an implementation of a managed