summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commita21ddf8192beb4ceb05af69c28980fd5f346e1a3 (patch)
tree5e169c5fc604a17533172614df8507a106f63fda
parent09245f698f6fb0c419255f2c671dd8eca5862f1b (diff)
downloadguix-patches-a21ddf8192beb4ceb05af69c28980fd5f346e1a3.tar
guix-patches-a21ddf8192beb4ceb05af69c28980fd5f346e1a3.tar.gz
gnu: bcachefs-tools-static: Rename.
* gnu/packages/file-systems.scm (bcachefs-tools-static): Rename this… (bcachefs-tools-minimal-static): …to this. Adjust all users. Change-Id: I26f28668d3c0297c09f18cbb5f73a876152612e7
-rw-r--r--gnu/packages/file-systems.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 8a069208f0..0499c9f755 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -765,10 +765,14 @@ performance and other characteristics.")
(list bcachefs-tools-minimal)
(list))))))
-(define-public bcachefs-tools/static
+(define-public bcachefs-tools-minimal/static
+ ;; The static variant is public for consistency with the other file system
+ ;; tools packages, but ours is based on the private minimal package. We
+ ;; don't need/want a bcachefs with FUSE support in the initrd, and nobody
+ ;; is likely to complain about the lack of a non-minimal bcachefs-static…
(package
(inherit bcachefs-tools-minimal)
- (name "bcachefs-tools-static")
+ (name "bcachefs-tools-minimal-static")
(arguments
(substitute-keyword-arguments (package-arguments bcachefs-tools-minimal)
((#:phases phases #~%standard-phases)
@@ -811,7 +815,7 @@ performance and other characteristics.")
(define-public bcachefs/static
(package
(name "bcachefs-static")
- (version (package-version bcachefs-tools/static))
+ (version (package-version bcachefs-tools-minimal/static))
(source #f)
(build-system trivial-build-system)
(arguments
@@ -824,13 +828,13 @@ performance and other characteristics.")
(dirname target))
(remove-store-references target)))))
(inputs
- (list bcachefs-tools/static))
- (home-page (package-home-page bcachefs-tools/static))
+ (list bcachefs-tools-minimal/static))
+ (home-page (package-home-page bcachefs-tools-minimal/static))
(synopsis "Statically-linked bcachefs command from bcachefs-tools")
(description
"This package provides the statically-linked @command{bcachefs} from a
minimal bcachefs-tools package. It is meant to be used in initrds.")
- (license (package-license bcachefs-tools/static))))
+ (license (package-license bcachefs-tools-minimal/static))))
(define-public exfatprogs
(package