summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-09-04 02:30:42 +0200
committerAndreas Enge <andreas@enge.fr>2024-09-21 09:24:23 +0200
commit6c137dcf84f2fbb4c1acc9d0b2eff3fe0a072407 (patch)
tree355aa5b99a81eeac899981c2908ac260f8385d3b
parent2c54c2db410ebdda8cd71716315e4ea4d31befbd (diff)
downloadguix-patches-6c137dcf84f2fbb4c1acc9d0b2eff3fe0a072407.tar
guix-patches-6c137dcf84f2fbb4c1acc9d0b2eff3fe0a072407.tar.gz
gnu: Add r-dtwclust.
* gnu/packages/cran.scm (r-dtwclust): New variable. Change-Id: I411d25b5df8f9bf923e60602901105a612c42fe9 Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/cran.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 13b92bb6f1..d8e07c6ed6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10972,6 +10972,55 @@ for sequence alignment, masking of sequence alignments, and estimation of
phylogenies and ancestral character states.")
(license license:gpl3)))
+(define-public r-dtwclust
+ (package
+ (name "r-dtwclust")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dtwclust" version))
+ (sha256
+ (base32 "0by01x4qpf1pin5l61wmm600bmsnlnns9knwb0qmjlj72pmwfkqh"))))
+ (properties `((upstream-name . "dtwclust")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-clue
+ r-cluster
+ r-dplyr
+ r-dtw
+ r-flexclust
+ r-foreach
+ r-ggplot2
+ r-ggrepel
+ r-matrix
+ r-proxy
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-rcppthread
+ r-reshape2
+ r-rlang
+ r-rspectra
+ r-shiny
+ r-shinyjs))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/asardaes/dtwclust")
+ (synopsis
+ "Clustering time series with dynamic time warping distance optimization")
+ (description
+ "This package implements time series clustering along with optimized
+techniques related to the dynamic time warping distance and its corresponding
+lower bounds. The implementations of partitional, hierarchical, fuzzy, k-Shape
+and TADPole clustering are available. Functionality can be easily extended with
+custom distance measures and centroid definitions. Implementations of @acronym{
+DTW, dynamic time warping} barycenter averaging, a distance based on global
+alignment kernels, and the soft-DTW distance and centroid routines are also
+provided. All included distance functions have custom loops optimized for the
+calculation of cross-distance matrices, including parallelization support.
+Several cluster validity indices are included.")
+ (license license:gpl3)))
+
(define-public r-dtw
(package
(name "r-dtw")