summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-09-15 10:58:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-18 14:36:43 +0200
commit0054e16886ed3b1358867ee4e19b665d79d67fdb (patch)
treecd9a63a1db370269eb42afdeaf261bf5b57726fc
parent4d58773989b024ecf801b0c8acd7f36e1c5888c5 (diff)
downloadguix-patches-0054e16886ed3b1358867ee4e19b665d79d67fdb.tar
guix-patches-0054e16886ed3b1358867ee4e19b665d79d67fdb.tar.gz
gnu: Add cl-utf8-input-stream.
* gnu/packages/lisp-xyz.scm (sbcl-utf8-input-stream, cl-utf8-input-stream, ecl-utf8-input-stream): New variables. Change-Id: Ifadfa8d8f2458fc1ff0f1f809682cd8805c6c077 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4efe611d7b..8e79458237 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -30514,6 +30514,36 @@ the abstraction and portability layer as thin as possible.")
(define-public ecl-usocket
(sbcl-package->ecl-package sbcl-usocket))
+(define-public sbcl-utf8-input-stream
+ (let ((commit "d33b57a4d439c2f0877e5513be45eb6940d92c68")
+ (revision "0"))
+ (package
+ (name "sbcl-utf8-input-stream")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/veer66/utf8-input-stream")
+ (commit commit)))
+ (file-name (git-file-name "cl-utf8-input-stream" version))
+ (sha256
+ (base32 "06fk8fsz9nngdfjymg93h1l5m4yhfg4w8as68zlaj698xf9ry3i5"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-babel sbcl-trivial-gray-streams))
+ (home-page "https://github.com/veer66/utf8-input-stream")
+ (synopsis "UTF-8 string input stream over a binary stream for Common
+Lisp")
+ (description "This package provides a UTF-8 string input stream over a
+binary stream for Common Lisp.")
+ (license license:expat))))
+
+(define-public cl-utf8-input-stream
+ (sbcl-package->cl-source-package sbcl-utf8-input-stream))
+
+(define-public ecl-utf8-input-stream
+ (sbcl-package->ecl-package sbcl-utf8-input-stream))
+
(define-public sbcl-utils-kt
(let ((commit "4adfe2889036ab5ffdd3cc2182ca2cc692bf11ff"))
(package