summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-18 19:38:01 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-19 17:25:48 +0800
commita144861ee09a52368c2fb379bbf2fa6d41c94a2e (patch)
tree84bc94b318a33fc884a07bd5151f90b6dcd8f2ed
parent610b395424c02274800d85585cb542ad66d9afea (diff)
downloadguix-patches-a144861ee09a52368c2fb379bbf2fa6d41c94a2e.tar
guix-patches-a144861ee09a52368c2fb379bbf2fa6d41c94a2e.tar.gz
gnu: progress: Update to 0.17.
* gnu/packages/admin.scm (progress): Update to 0.17. [arguments]: Use G-expressions. Use PKG-CONFIG-FOR-TARGET. Change-Id: Ic92f305e7200cd808aeab552966ba9374f568f59
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d73f017912..4910327d99 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -277,7 +277,7 @@ usual file attributes can be checked for inconsistencies.")
(define-public progress
(package
(name "progress")
- (version "0.16")
+ (version "0.17")
(source
(origin
(method git-fetch)
@@ -285,7 +285,7 @@ usual file attributes can be checked for inconsistencies.")
(url "https://github.com/Xfennec/progress")
(commit (string-append "v" version))))
(sha256
- (base32 "0gf10j9zd8spain94b5kigknwbdqajiy6fjsa5hhwsc1biz34hcj"))
+ (base32 "1cg1vdk2891sdcbn7yc9a6mzdxplm63qsk1kq0jr4j8ym28v09xf"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
@@ -293,18 +293,14 @@ usual file attributes can be checked for inconsistencies.")
(inputs
(list ncurses))
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (let ((target ,(%current-target-system)))
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "PKG_CONFIG="
- (if target
- (string-append target "-pkg-config")
- "pkg-config"))
- (string-append "PREFIX=" (assoc-ref %outputs "out"))))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list #:tests? #f ; no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/Xfennec/progress")
(synopsis "Program to view the progress of the coreutils commands")
(description "A program that looks for coreutils basic commands (cp, mv,