summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-09-20 15:07:47 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-25 16:02:18 +0200
commitbd67531b82a72155d02a8d756b0f4fbd6e04c0c5 (patch)
tree3dd6622a90c377997354b711d997f517785dbd80
parent039635567d17460d8d541caa58897db83a3565a8 (diff)
downloadguix-patches-bd67531b82a72155d02a8d756b0f4fbd6e04c0c5.tar
guix-patches-bd67531b82a72155d02a8d756b0f4fbd6e04c0c5.tar.gz
gnu: python-pyfaidx: Add dependency on UTF-8 locales for tests.
Fixes a regression introduced in 92727f4af5d410b0a521d57d5ecef6b35779bdc2 whereby the “en_US.utf8” locale would no longer be available in the build environment. * gnu/packages/bioinformatics.scm (python-pyfaidx)[native-inputs]: Add ‘libc-utf8-locales-for-target’. Change-Id: I4f868edb82ef08bb56e5d7e3d2ea861bd23c03bf
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0206ebe1a3..ad7baad590 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -18513,7 +18513,8 @@ bgzipped text file that contains a pair of genomic coordinates per line.")
(("dynamic = \\[\"version\"\\]")
(string-append "version = \"" #$version "\""))))))))
(native-inputs
- (list python-fsspec
+ (list (libc-utf8-locales-for-target) ;tests need "en_US.utf8"
+ python-fsspec
python-mock
python-numpy
python-pytest