summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-09-23 07:04:02 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 13:17:50 +0900
commitfe9d09dca4674c1a309eefe5fbf324c61ba975d1 (patch)
tree2fef75e647fa77c1af3c0e19bf7c19e4254a33ae
parentadd9662686f74a39ea4f3fa75c5b81b1debb9a67 (diff)
downloadguix-patches-fe9d09dca4674c1a309eefe5fbf324c61ba975d1.tar
guix-patches-fe9d09dca4674c1a309eefe5fbf324c61ba975d1.tar.gz
gnu: Add cppgir.
* gnu/packages/glib.scm (cppgir): New variable. Change-Id: Ic4510be6d05b7b3977aa457c6a7fec382c1d3a88 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/glib.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d6275ea63e..a479199cdd 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages popt)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
@@ -1592,3 +1594,30 @@ authors who want to manage concurrent code.
Dex also provides Fibers which allow writing synchronous looking code in C
that uses asynchronous and future-based APIs.")
(license license:lgpl2.1+)))
+
+(define-public cppgir
+ (package
+ (name "cppgir")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.com/mnauw/cppgir")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cj4myqzb28hgb7zlxlba9y8n4ysxkvv2y9wy6f7ps58mr18h7bl"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DINTERNAL_EXPECTED=OFF")))
+ (inputs (list boost fmt expected-lite))
+ (home-page "https://gitlab.com/mnauw/cppgir")
+ (synopsis "C++ bindings generator for GObject introspection")
+ (description "cppgir processes @file{.gir} files derived from GObject
+introspection annotations into a set of C++ files defining suitable
+namespaces, classes and other types that together form a C++ binding.")
+ (license license:expat)))