summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-09-15 10:58:54 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-18 14:36:43 +0200
commit40dbae7fe4de91af4eb2dae2ee88e369de83698b (patch)
treedcf3132642e4f37101a30045eae7369a885dcda4
parent0054e16886ed3b1358867ee4e19b665d79d67fdb (diff)
downloadguix-patches-40dbae7fe4de91af4eb2dae2ee88e369de83698b.tar
guix-patches-40dbae7fe4de91af4eb2dae2ee88e369de83698b.tar.gz
gnu: Add cl-bnf.
* gnu/packages/lisp-xyz.scm (sbcl-cl-bnf, cl-bnf, ecl-cl-bnf): New variables. Change-Id: Ib37a839feff579753d7f11c0fdb212dbb685773a Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8e79458237..0f8023505e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4260,6 +4260,35 @@ encoding table that uses only URI-compatible characters.")
(define-public ecl-cl-base64
(sbcl-package->ecl-package sbcl-cl-base64))
+(define-public sbcl-cl-bnf
+ (let ((commit "ce009e3d60697bc376116e988f29ec0cbb1e9c84")
+ (revision "0"))
+ (package
+ (name "sbcl-cl-bnf")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/diasbruno/cl-bnf")
+ (commit commit)))
+ (file-name (git-file-name "cl-bnf" version))
+ (sha256
+ (base32 "0aa7hnkj71f37lxzlhsppwcmk3yv42hclq08c4jrdnv8jmdb8r0l"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-flexi-streams sbcl-utf8-input-stream))
+ (home-page "https://github.com/diasbruno/cl-bnf")
+ (synopsis "BNF parser in Common Lisp")
+ (description "This package provides a @acronym{BNF, Backus–Naur form}
+parser in Common Lisp.")
+ (license (list license:expat)))))
+
+(define-public cl-bnf
+ (sbcl-package->cl-source-package sbcl-cl-bnf))
+
+(define-public ecl-cl-bnf
+ (sbcl-package->ecl-package sbcl-cl-bnf))
+
(define-public sbcl-cl-cairo2
(let ((commit "41ae45aac86553c46f4bb460f80e1fb620930f5b")
(revision "1"))