summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2024-09-04 20:37:26 -0700
committerGuix Patches Tester <>2024-09-05 06:11:08 +0200
commitabc337a8527f5589d93592290d4ff8bb64a18024 (patch)
tree6663be7a4d03264eff24f50be6d63a474264b9d3
parented95ddeb1e58c314f2e22b4cd35986042f3e2f21 (diff)
downloadguix-patches-issue-72777.tar
guix-patches-issue-72777.tar.gz
gnu: dhewm3: Update to 1.5.4.issue-72777
* gnu/packages/game-development.scm: (dhewm3): Update to 1.5.4. [arguments]: Set configure flags for 32-bit builds. Change-Id: I8db801b099910e60e85d0da7ddcc77654205107f
-rw-r--r--gnu/packages/game-development.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 62f578f3db..0723cb49f3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3091,7 +3091,7 @@ game engine. id Tech 2 is the engine originally behind Quake 2.")
(define-public dhewm3
(package
(name "dhewm3")
- (version "1.5.3")
+ (version "1.5.4")
(source (origin
(method git-fetch)
(uri (git-reference (url "https://github.com/dhewm/dhewm3")
@@ -3099,10 +3099,15 @@ game engine. id Tech 2 is the engine originally behind Quake 2.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zbwhrngmgb0969izmxididyx892qk7591aa9mbigakw6dvmlm84"))))
+ "16cvf78a7q00bkf74waj6gss09y4iqn3zl9srsfg6i7336gjm2wn"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ; No tests.
+ #:configure-flags
+ ;; Needed to fix 32bit builds.
+ #~(if (not #$(target-64bit?))
+ (list "-DCMAKE_CXX_FLAGS=-D_FILE_OFFSET_BITS=64")
+ '())
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'change-to-build-dir