summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-04 10:40:43 +0300
committerGuix Patches Tester <>2024-09-04 10:01:19 +0200
commit58746a2e1bf20374090ffc081da9d14c5d00c5ed (patch)
tree1112e7ce6d08b631f4c87f4193efd4322062c6c7
parent7fa9df431e9423e2b79c8c520de1d0ef7aed910d (diff)
downloadguix-patches-issue-72957.tar
guix-patches-issue-72957.tar.gz
gnu: Add bin-graph.issue-72957
* gnu/packages/linux.scm (bin-graph): New variable. Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a3b63a6f62..76de4be816 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1776,6 +1776,40 @@ emulate optical devices such as DVD and CD-ROM drives.")
graphics card on Optimus laptops.")
(license license:gpl2))))
+(define-public bin-graph
+ ;; XXX: The upstream does not have tags yet.
+ (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
+ (revision "0"))
+ (package
+ (name "bin-graph")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/8dcc/bin-graph")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
+ (arguments
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ (string-append "INSTALL_DIR=" #$output "/bin"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (build-system gnu-build-system)
+ (inputs (list libpng))
+ (home-page "https://github.com/8dcc/bin-graph")
+ (synopsis "Visualize binary files")
+ (description
+ "@code{bin-graph} provides a simple way of visualizing the different regions
+of a binary file.")
+ (license license:gpl3))))
+
(define-public ddcci-driver-linux
(package
(name "ddcci-driver-linux")