summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-09-02 19:07:17 +0900
committerGuix Patches Tester <>2024-09-02 13:33:19 +0200
commite972e70415e40177b28f5ce1dcdefded9aafaaf6 (patch)
tree7a95e36ada7be7ccdf9b364c1aa6a73b14dd699f
parent3c21d0da62b3d6832dd1ab450d8ab50ab8d38f27 (diff)
downloadguix-patches-issue-72958.tar
guix-patches-issue-72958.tar.gz
gnu: Add ruby-rubocop-itamae.issue-72958
* gnu/packages/ruby.scm (ruby-rubocop-itamae): New variable. Change-Id: Ic5679a92c5e5faf420ed7f49acb7d9e28430bff4
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..7b82ebd58e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1996,6 +1996,35 @@ code style checking of Capybara test files (RSpec, Cucumber, Minitest).")
ruby-simplecov
ruby-yard))))
+(define-public ruby-rubocop-itamae
+ (package
+ (name "ruby-rubocop-itamae")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sue445/rubocop-itamae")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cynpafby3v6psg94whix2z9fhpdh669w9imm92zsjpbdgsxpmd7"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec" "-Ilib" "-Ispec" "spec")))))))
+ (native-inputs (list ruby-rspec))
+ (propagated-inputs (list ruby-rubocop))
+ (synopsis "Code style checking for Itamae recipes")
+ (description "This RuboCop plugin is for checking the code style of Itamae
+configuration management system recipes.")
+ (home-page "https://github.com/sue445/rubocop-itamae")
+ (license license:expat)))
+
;;; A minimal variant used to build ruby-rubocop itself.
(define ruby-rubocop-rake-minimal
(package