summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty10@gmail.com>2024-09-08 01:01:24 +0530
committerGuix Patches Tester <>2024-09-07 22:11:54 +0200
commite3c28f374c259b28415c570170726e15b392e93f (patch)
tree5b2fd4efcbf94e7720dadef9528f864a8eb2ddab
parent7403ccdbfc3bd179b156177f45516ea6dc2bbbc8 (diff)
downloadguix-patches-issue-73019.tar
guix-patches-issue-73019.tar.gz
gnu: Add blackbox-terminal.issue-73019
* gnu/packages/gnome-xyz.scm (blackbox-terminal-0.14.0): New public variable. Change-Id: I3f95a4d9d2ecc5767e04f675d1fcf83649d684df
-rw-r--r--gnu/packages/gnome-xyz.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index c5abcbb14d..5a2a5bf629 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages ibus)
#:use-module (gnu packages inkscape)
#:use-module (gnu packages image)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
@@ -1795,3 +1796,67 @@ way they prefer.")
(synopsis "Utility library for GNOME apps")
(description "Utility library for GNOME apps.")
(license license:gpl3)))
+
+(define-public blackbox-terminal
+ (package
+ (name "blackbox-terminal")
+ (version "0.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/raggesilver/blackbox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g7n2z0m7jjbn93zvx3ix7ph4mpncwq80cjjc2prp878cksj3g3r"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags `("-Dblackbox_is_flatpak=false")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-gtk4-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache")
+ "gtk4-update-icon-cache")))))))
+ (native-inputs (list pkg-config
+ vala
+ python-3.10
+ desktop-file-utils ;for update-desktop-database
+ `(,glib "bin") ;for glib-compile-schemas, etc.
+ `(,gtk "bin") ;gtk4-update-icon-cache
+ gettext-minimal))
+ (inputs (list gtk
+ vte-gtk-4-with-sixel
+ json-glib
+ libpqmarble
+ libadwaita
+ pcre2
+ ;; libxml2 and libgee are also required to build
+ ;; but meson fails to catch it.
+ libxml2
+ libgee
+ ;; The build won't fail without librsvg, but
+ ;; since it is a dependency, it has been included.
+ librsvg))
+ (home-page "https://gitlab.gnome.org/raggesilver/blackbox/")
+ (synopsis "Black Box is an elegant and customizable terminal for GNOME.")
+ (description
+ "An elegant and customizable terminal for GNOME:
+@itemize
+@item Color schemes - (Tilix compatible color scheme support)
+@item Theming - your color scheme can be used to style the whole app
+@item Background transparency
+@item Custom fonts, padding, and cell spacing
+@item Tabs
+@item Support for drag and dropping files
+@item Sixel (experimental)
+@item Customizable keybindings
+@item Toggle-able header bar
+@item Search your backlog with text or regex
+@item Context aware header bar - the header bar changes colors when running commands with sudo and in ssh sessions
+@item Desktop notifications - get notified when a command is finished in the background
+@item Customizable UI
+@end itemize")
+ (license license:gpl3)))