summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-09-16 18:29:58 +0200
committerGuix Patches Tester <>2024-09-18 12:17:02 +0200
commit79bdd62f1ded95228eca216b013fdbe624c3b697 (patch)
tree7f5c329aab83242bebd50b415ccc94772999bde8
parent8915e16ad1fe6a962e30089c36955596f336489d (diff)
downloadguix-patches-issue-73126.tar
guix-patches-issue-73126.tar.gz
gnu: Add inadyn.issue-73126
* gnu/packages/dns.scm (inadyn): Add variable. (unbound): Remove trailing whitespace. Change-Id: I47ba0f6c3537b963623011d1862aa4abf528b53b
-rw-r--r--gnu/packages/dns.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 7a584ad6a2..ec39cc445b 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -78,6 +79,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
@@ -714,7 +716,7 @@ struct protoent *getprotobyname(const char *name) {
p->p_name = \"udp\";
p->p_proto = 17;
p->p_aliases[0] = \"UDP\";
- } else
+ } else
p = NULL;
return p;
}
@@ -750,7 +752,7 @@ struct servent *getservbyname(const char *name, const char *proto) {
s->s_name = \"domain\";
s->s_port = htons(53);
s->s_proto = buf;
- } else
+ } else
s = NULL;
return s;
}
@@ -790,6 +792,27 @@ localhost, reverse for @code{127.0.0.1} and @code{::1}, and NXDOMAIN for zones
served by AS112. Stub and forward zones are supported.")
(license license:bsd-4)))
+(define-public inadyn
+ (package
+ (name "inadyn")
+ (version "2.12.0")
+ (source (git-source
+ "1a9i9ayxcvgcvj1b68wl9mkgrzp9a42w2rcgbmsp2s03ffvcj0b9"
+ "github.com" "troglobit" name version "v"))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags (list "--localstatedir=/var")))
+ (inputs (list libconfuse gnutls))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (home-page "https://troglobit.com/projects/inadyn")
+ (synopsis "Dynamic DNS (DDNS) client with HTTPS support")
+ (description
+ "In-a-Dyn is a small and simple Dynamic DNS (DDNS) client with
+HTTPS support. DDNS is used in off-the-shelf routers and Internet
+gateways to automate the task of keeping your DNS record up to date with
+any IP address changes from your ISP. DDNS can also be used in
+installations with redundant (backup) connections to the Internet.")
+ (license license:gpl2)))
+
(define-public yadifa
(package
(name "yadifa")