summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2024-09-10 21:19:50 +0200
committerGuix Patches Tester <>2024-09-10 22:58:11 +0200
commitf6c325ef6ed8cdcef1b3557d5d431b4800ec2c41 (patch)
tree06d48a0922627ac339164a25f7cd87759805d027
parentf977cb2b609f7122db2cf026cac5ab9d6d44a206 (diff)
downloadguix-patches-issue-73173.tar
guix-patches-issue-73173.tar.gz
gnu: Update python-rdflib to 7.0.0.issue-73173
* gnu/packages/rdf.scm: Add updated recipe for python-rdflib; Keep python-rdflib-6 for compatibility. * gnu/packages/python-xyz.scm: Build python-prov with python-rdflib-6 because rdflib-7 is not supported. * gnu/packages/bioinformatics.scm: Build cwltool with python-rdflib-6 because it fails to build with rdflib-7. Change-Id: Ibc40c16ede20e69e702915488d6b2f0a7e70b868
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/rdf.scm43
3 files changed, 45 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4653360792..db8befd144 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5786,7 +5786,7 @@ documents.")
python-prov
python-pydot
python-psutil
- python-rdflib
+ python-rdflib-6
python-requests
python-ruamel.yaml
python-schema-salad
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9dd963e396..3dbb3edacd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24998,7 +24998,7 @@ manipulation, or @code{stdout}.")
(("\\.serialize\\(format=\"nt\"\\)")
".serialize(format=\"nt\", encoding=\"utf-8\")")))))))
(propagated-inputs
- (list python-dateutil python-lxml python-networkx python-rdflib))
+ (list python-dateutil python-lxml python-networkx python-rdflib-6))
(native-inputs
(list graphviz python-pydot))
(home-page "https://github.com/trungdong/prov")
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index f10b530861..9a02a71d81 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -330,6 +330,49 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(define-public python-rdflib
(package
(name "python-rdflib")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rdflib" version))
+ (sha256
+ (base32
+ "1blmx4v003afr3l9qg84ymj0sldcbsr2dzdgq6w5k022d62yp5cr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (for-each delete-file
+ '(;; The tests in this file miss a test fixture.
+ ;; fixture 'no_cover' not found
+ "test/test_misc/test_plugins.py"
+ ;; These tests need internet access.
+ "test/jsonld/test_onedotone.py"
+ "test/test_examples.py"
+ "test/test_extras/test_infixowl/test_basic.py"
+ "test/test_extras/test_infixowl/test_context.py"
+ "test/test_sparql/test_service.py"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "test/")))))))
+ (native-inputs
+ (list python-pytest python-poetry-core))
+ (propagated-inputs
+ (list python-html5lib python-isodate python-pyparsing))
+ (home-page "https://github.com/RDFLib/rdflib")
+ (synopsis "Python RDF library")
+ (description
+ "RDFLib is a Python library for working with RDF, a simple yet
+powerful language for representing information.")
+ (license (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))
+
+(define-public python-rdflib-6
+ (package
+ (name "python-rdflib")
(version "6.1.1")
(source
(origin