summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Covrig <aaron.covrig.us@ieee.org>2024-09-18 17:14:50 -0400
committerGuix Patches Tester <>2024-09-24 11:21:41 +0200
commit61933dc9098127db480a08e1114d05724cc3900c (patch)
treefc5699a66bd8ac8faf6f634dec0fa730965d3e4a
parentce6240fa34b16ed57f5275d159a08b59eb540e7b (diff)
downloadguix-patches-issue-73339.tar
guix-patches-issue-73339.tar.gz
gnu: pypandoc: Update to 1.13 and fix dependenciesissue-73339
* gnu/packages/python-xyz.scm (pypandoc): Update to 1.13 [inputs]: Add texlive-xpatch
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6975cca1f7..7551fc8382 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32393,31 +32394,33 @@ By default it uses the open Python vulnerability database Safety DB.")
(define-public python-pypandoc
(package
(name "python-pypandoc")
- (version "1.7.5")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypandoc" version))
(sha256
- (base32
- "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
+ (base32 "07hw2psqzaffskmgb789f0zbra9cc17ykl8baw1jn34nqxrj0r9i"))))
(build-system python-build-system)
- (inputs
- (list pandoc python-pandocfilters))
- (propagated-inputs
- `(("wheel" ,python-wheel)))
- (native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
+ (inputs (list pandoc python-pandocfilters texlive-xpatch))
+ (propagated-inputs `(("wheel" ,python-wheel)))
+ (native-inputs `(("texlive" ,(texlive-updmap.cfg (list texlive-lm
+ texlive-xcolor)))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-tests
- (lambda _
- ;; Disable test requiring network access
- (substitute* "tests.py"
- (("test_basic_conversion_from_http_url")
- "skip_test_basic_conversion_from_http_url"))
- #t)))))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ (substitute* "tests.py"
+ ;; Disable test requiring network access
+ (("test_basic_conversion_from_http_url")
+ "skip_test_basic_conversion_from_http_url")
+ ;; Disable tests with missing files
+ (("test_basic_conversion_from_file_pattern")
+ "skip_test_basic_conversion_from_file_pattern")
+ (("test_conversion_with_data_files")
+ "skip_test_conversion_with_data_files")
+ (("test_conversion_stderr")
+ "skip_test_conversion_stderr")) #t)))))
(home-page "https://github.com/bebraw/pypandoc")
(synopsis "Python wrapper for pandoc")
(description "pypandoc is a thin Python wrapper around pandoc