summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-19 16:36:33 +0900
committerGuix Patches Tester <>2024-09-24 11:29:26 +0200
commit4d61d320e926d5489c32bf60c89d7ed7a8ec0aa9 (patch)
tree5d471788c213e9df43c10a24badf9d45cd1b1dac
parent5dd07b61a03270b11818add478697a938f93b183 (diff)
downloadguix-patches-issue-73350.tar
guix-patches-issue-73350.tar.gz
gnu: Add sdl-jstest.issue-73350
* gnu/packages/games.scm (sdl-jstest): New variable. Change-Id: I8a2845375501ddadca2eb4add869fce1dc277568
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5720d17bb3..a01a2f16f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11406,6 +11406,45 @@ do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
(license license:cc-by4.0))))
+(define-public sdl-jstest
+ (package
+ (name "sdl-jstest")
+ (version "0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Grumbel/sdl-jstest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11qp4gkbb11n3wx74128fj56radgsvkj7nxhbh55rd3xad1hckh3"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; The test suite uses appstream-utils to validate the appdata.xml file,
+ ;; fails with "url-not-found".
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-gamecontroller-db
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (copy-file
+ (search-input-file (or native-inputs inputs)
+ "share/sdl2/gamecontrollerdb.txt")
+ "external/sdl_gamecontrollerdb/gamecontrollerdb.txt"))))))
+ (native-inputs
+ (list pkg-config sdl2-gamecontrollerdb tinycmmc))
+ (inputs (list ncurses sdl sdl2))
+ (home-page "https://github.com/Grumbel/sdl-jstest")
+ (synopsis "SDL Joystick Tester")
+ (description "The @command{sdl-jstest} and @command{sdl2-jstest} commands
+can list the available joystick controllers as found by the SDL or SDL2
+libraries, respectively. It can show the available axes, buttons, hats and
+balls of a chosen controller, and can display the controller actions in real
+time in a visual fashion.")
+ (license license:gpl3+)))
+
(define-public sdlpop
(package
(name "sdlpop")