summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-24 12:39:25 +0100
committerGuix Patches Tester <>2024-09-24 13:56:36 +0200
commitc344612a61d15866c6f25d8471523cabcb7cff80 (patch)
tree59a8c4c215a5d7f8527df7fe822bfe7af6984c25
parentdfab637246971ba6f7a2e21b0a66ba5fbb8a3483 (diff)
downloadguix-patches-issue-73449.tar
guix-patches-issue-73449.tar.gz
gnu: Add python-country-converter.issue-73449
* gnu/packages/iso-codes.scm (python-country-converter): New variable. Change-Id: Ib40f94c22b297de02a2ab16b143dcfa59e3a5bdd
-rw-r--r--gnu/packages/iso-codes.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
index d2bace6a3c..746f3ce0ba 100644
--- a/gnu/packages/iso-codes.scm
+++ b/gnu/packages/iso-codes.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,9 +26,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
+ #:use-module (gnu packages check)
#:use-module (gnu packages gettext)
#:use-module (gnu packages perl)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-science))
(define-public iso-codes/official
;; This package variant is intended for ‘external’ use, such as users running
@@ -87,6 +91,44 @@ information.")
(("(Taiwan), [^\"]*" _ name) name))))))
(synopsis "Various ISO standards as used by GNU@tie{}Guix"))))
+(define-public python-country-converter
+ (package
+ (name "python-country-converter")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch) ;no test data in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/IndEcol/country_converter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i1nlbahfwgx1f5q4ib32539xmc694834s0flzp0wlki0hwzd4rd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-pandas))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/IndEcol/country_converter")
+ (synopsis "Auto conversion from different country name standards")
+ (description
+ "The country converter (coco) automates the conversion from different
+standards and version of country names. Internally, coco is based on a table
+specifying the different ISO and UN standards per country together with the
+official name and a regular expression which aim to match all English versions
+of a specific country name. In addition, coco includes classification based
+on UN-, EU-, OECD-membership, UN regions specifications, continents and
+various MRIO and IAM databases.
+
+Supported classification schemas: APEC, BASIC, BRIC, CC41, CIS, Cecilia 2050
+classification, DACcode, EEA membership, EU membership, EXIOBASE 1
+classification, EXIOBASE 2 classification, EXIOBASE 3 classification, Eora,
+FAOcode, G20, G7, GBDcode, GWcode, IEA, IMAGE, IOC ISO 3166-1 alpha-2, ISO
+3166-1 alpha-3, ISO 3166-1 numeric, MESSAGE 11-region classification, OECD
+membership, REMIND, Schengen region, UN membership, UN numeric code, UN
+region, WIOD classification, ccTLD.")
+ (license license:gpl3)))
+
(define-public python-iso639
(package
(name "python-iso639")