summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel van der Boom <marcel@van-der-boom.nl>2024-09-27 13:14:41 +0200
committerGuix Patches Tester <>2024-09-27 13:45:13 +0200
commita547cc21c82a054404ed334b25c616073538cefd (patch)
treee39dd26eb3ad854d313b7f27da983357c2039763
parenta75387f8eeaacb242af66073c838485df1e87a10 (diff)
downloadguix-patches-issue-73514.tar
guix-patches-issue-73514.tar.gz
gnu: lib2geom: Skip a test on ppc64leissue-73514
* gnu/packages/graphics.scm (lib2geom)[arguments]: When building for ppc64le-linux add a phase to skip a test known to fail upstream.
-rw-r--r--gnu/packages/graphics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7ed5cdc92d..b32ac118c9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -964,7 +964,8 @@ exception-handling library.")
(("self-intersections-test") ""))))))
;; See https://gitlab.com/inkscape/lib2geom/-/issues/63
((or (target-aarch64?)
- (target-riscv64?))
+ (target-riscv64?)
+ (target-ppc64le?))
#~((add-after 'unpack 'fix-aarch64-faulty-test
(lambda _
(substitute* "tests/CMakeLists.txt"