summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2024-09-09 16:28:23 +0200
committerGuix Patches Tester <>2024-09-09 17:17:47 +0200
commit2613829a1e7bc616212b2f0cc406055d70766172 (patch)
tree56298945a6f954e39b5b32e40b107649352b5c91
parent0b6748bad65d855187c32604aa359a53b4f82b2e (diff)
downloadguix-patches-issue-73148.tar
guix-patches-issue-73148.tar.gz
gnu: python-trezor-agent: Use absolute path for gpg at runtime.issue-73148
The trezor-gpg binary execs gnupg at runtime. Prior to this fix it wouldn't work in a profile where gpg wasn't in the PATH. * gnu/packages/finance.scm (python-trezor-agent): Substitute absolute path for the gpgconf binary (and with that to all gnupg binaries). Fixes #57345. Change-Id: I9acc5a31a1189d0121152c2bd9ba0ff5eb90af09
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 841f128d09..e4a5ef829b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -951,6 +951,11 @@ Bech32 and segwit addresses.")
(lambda _
(substitute* "setup.py"
(("'backports.shutil_which>=3.5.1',") ""))))
+ (add-after 'unpack 'set-gpgconf-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "libagent/gpg/keyring.py"
+ (("util\\.which\\('gpgconf'\\)")
+ (string-append "'" (search-input-file inputs "bin/gpgconf") "'")))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -978,9 +983,10 @@ Bech32 and segwit addresses.")
python-semver
python-unidecode
python-wheel))
- (native-inputs ; Only needed for running the tests
- (list gnupg
- python-mock
+ (inputs
+ (list gnupg))
+ (native-inputs ; Only needed for running the tests
+ (list python-mock
python-pytest))
(home-page "https://github.com/romanz/trezor-agent")
(synopsis "Use hardware wallets as SSH and GPG agent")