summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 841f128d09..e4a5ef829b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -951,6 +951,11 @@ Bech32 and segwit addresses.")
(lambda _
(substitute* "setup.py"
(("'backports.shutil_which>=3.5.1',") ""))))
+ (add-after 'unpack 'set-gpgconf-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "libagent/gpg/keyring.py"
+ (("util\\.which\\('gpgconf'\\)")
+ (string-append "'" (search-input-file inputs "bin/gpgconf") "'")))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -978,9 +983,10 @@ Bech32 and segwit addresses.")
python-semver
python-unidecode
python-wheel))
- (native-inputs ; Only needed for running the tests
- (list gnupg
- python-mock
+ (inputs
+ (list gnupg))
+ (native-inputs ; Only needed for running the tests
+ (list python-mock
python-pytest))
(home-page "https://github.com/romanz/trezor-agent")
(synopsis "Use hardware wallets as SSH and GPG agent")